Problems in Orion Sandbox

orionsandbox

#1

Hi everyone,

Since Thursday(7/6/2018), I can’t play Orion Sandbox. :sweat: When I clicked the link, there was no main menu appear on my PC screen.

Hence, I cannot continue to play the game. Seriously, I’m very interested :smile: in this game but now I cannot play it anymore.

Could anyone help me to solve this problem? Thx


#2

After the game loaded, it appears like this instead of showing the main menu and the ‘Play’ button.

Any expert(s) please show me how to solve this problem. thx


#3

can you try playing on y8.com if same thing happen http://www.y8.com/games/orion_sandbox


#4

i haven’t been able to play orion sandbox enhanced either…have sent many emails but no response from Y8.com. This has happened before. I have the latest Adobe flash player and have allowed the flash to run on the site but still no game. Not sure what else to do.


#5

hi…you can’t play on Y8.com since it’s broken too. All orion games are not loading . please fix.


#6

Hi,

But I still cannot play Orion Sandbox either I’m play in Y8, or Crazygame, or any other websites but I still cannot play it. It will appear just like I post the picture yesterday.

My internet connection is okay, and I tried to play other games in Y8 that are not Orion Sandbox but that’s ok. Just the Orion games I can’t play.

I have played the Orion Sandbox game in my another computer but that’s okay. Just this computer!

I don’t know why? Maybe the developer needs to fix something about the game or give me some advice about my PC. Thx.


#7

Checking with developer thanks for the report.


#8

Hello, there was a recent Adobe update which apparently messed up the game. Dev will try to find a solution as soon as possible.


#9

please check now.


#10

Where did I have to check?

PC settings or … Where?

I mean the “Adobe Update”.

Thanks


#11

How can I check my Adobe Updates?

I mean where is the Adobe Flash updates?

thanks.


#12

Hi,


#13

I have one question about Orion Sandbox. That is how do I fill water into the bucket that I have purchased with iron ingots?

The problem is like this, when I’m going near the pond somewhere on the land, I tried to left click on the water and bucket but no sign about fully filled with water! It kept saying “empty bucket”.

Can someone teach me how to click something else, to make the bucket fully filled with water.

Thx.


#14

Hi, You have to be near the water with bucket in your hand and than click RIGHT mouse button (on the water) :slight_smile:


#15

Yes I done that “filling water with a bucket”. Thanks for your message.:slight_smile:


#16

Hi, everyone:

I have one question on the Orion Sandbox game. That is I want to make a christmas tree but I noticed that it required “Garlands”:astonished: and I don’t know how to get the “Garlands”.:stuck_out_tongue_closed_eyes:

Can anyone help me? Thx.:slight_smile:


#17

Hi,

How to get it? I mean the Garlands.

Anyone could help me?

Thx.


#18

Hi!
this is what you need to create Garlands:


#19

Hi Demkame,

I have read your reply and you mean I must finished all the quest until I get the Machinery reward?:astonished:

But now I haven’t finish all the quest, just only one.

Thanks for your help.:slight_smile::+1:


#20

Hi everyone,

I saw the ingredients needed to build the Garlands and I don’t know how to get that ingredients!

One battery and another one… What’s that?

Can anybody help me?

Thx.